TNG Mod Version Numbers for Beginners

From TNG_Wiki
Jump to: navigation, search

I recently added an email notification to Bart's Click Counter II code based on a mod provided by Jeff Robison and I am amazed at the number of obsolete mods or mods for old TNG versions being downloaded, so I thought I would write a quick overview of the meaning of TNG mod numbers and the Mods for TNG vNN category pages.

By obsolete mods, I mean mod versions that apply to previous TNG versions when there is a more current version of the mod that applies to the TNG version you are updating, and mods that been incorporated into TNG. For example if you are upgrading to the current TNG v11.1 mods that apply to TNG v7 or v8 are likely obsolete because new versions of the mod would have been created using the new Mod Guidelines with TNG v9 and may have been replaced by a different version of the mod for TNG 10.1 and later.

Mod Version Numbers

During the TNG v9 beta test, it was agreed among the mod developers that the first 3 positions of the mod version number would indicate the minimum TNG version to which that mod applies. For example, a mod v9.0.0.z applies to TNG v9.0.0 and after until a new mod version of the mod is required for it to install and work correctly. So v9.0.0.z mods may apply up to current TNG versions if no changes are required for the mod to install and work.

However, if the mod did not install on TNG 10.1 for example, then the TNG Wiki page for the mod may might show both a v9.0.0.z version and a v10.1.0.z of the mod. The v9.0.0.z version in that case would not work for TNG v10.1 and later, so there is no need to download it if you are installing or upgrading to TNG 11.1. Normally, the mods recent TNG version mods are shown in a push down stack approach on the TNG Wiki page. Icons are also used to show what TNG version for the mod.

I would not expect mods that applied to TNG v7 and v8 that did not follow the above naming conventions to be downloaded today because I would not expect TNG Users to be creating new web sites with TNG v7 and v8. Maybe since I attempt to keep my web site current that is something I am overlooking or do not understand.

Examples

The format for a TNG mod version number is vnn.x.y.z where nn.x.y is the minimum compatible TNG version, and z is the mod number used when having to make changes to the mod within a version for fixes or improvements to the mod.

  • vnn is the TNG version
v10 indicates that the minimum TNG version is version 10
  • x is the TNG release,
  • y is the TNG release modification number, and
  • z is the TNG mod number used when having to make changes to the mod between versions, starting with 0.

The following table illustrates the use of the mod version numbers.

TNG Mod Version Mod File name z value Meaning of the TNG Mod number
10.0.0  %version: v10.0.0.0% filename_v10.0.0.0.cfg 0 first mod for a new TNG version
10.0.0  %version: v10.0.0.1% filename_v10.0.0.1.cfg 1 fixed a bug in the Mod
10.0.0  %version: v10.0.0.2% filename_v10.0.0.2.cfg 2 fixed another bug in the Mod
10.0.1  %version: v10.0.0.2% filename_v10.0.0.2.cfg 2 no change required to the mod for new TNG release
10.0.2  %version: v10.0.2.3% filename_v10.0.2.3.cfg 3 change required for new TNG update
10.0.2  %version: v10.0.2.4% filename_v10.0.2.4.cfg 4 added new feature to mod
10.0.3  %version: v10.0.2.4% filename_v10.0.2.4.cfg 4 no change required in mod
10.1.0  %version: v10.0.2.4% filename_v10.0.2.4.cfg 4 no change required in mod
10.1.1  %version: v10.1.1.5% filename_v10.1.1.5.cfg 5 change required for new TNG release

Note that the TNG Mod v10.x.y.z is never higher than the TNG Version it applies to when compared at the first 3 digits and the z value is incremented continually across all TNG releases within a TNG version

Meaning of Icons

The icons used in the Download section indicates the minimum TNG version to which a specific mod zip file applies.

media-4_tooltip_v11.0.2.3.zip for
TNG 11.0.2
media-4_tooltip_v10.1.0.2.zip for
TNG 11.0
TNG 10.1.0
media-4_tooltip_v10.0.0.0.zip for
TNG 10.0
media-4_tooltip_v9.2.2.3.zip for
TNG 9.2.2
media-4_tooltip_v9.0.3.2.zip for
TNG 9.0.3
media-4_tooltip_v9.0.2.1.zip for
TNG 9.0.2
media-4_tooltip_v9.0.0.0.zip for
TNG 9.0
media-4_tooltip_v8.1.4.zip
TNG 8.1.2
media-4_tooltip_v8.1.3.zip for
TNG 8.1
media-4_tooltip_v8.1.1.zip for
TNG 8.0
for
TNG 7.0
  • media-4_tooltip_v1.2.zip if you are NOT using Bret Rumsey's Image Viewer
  • media-4_tooltip_w_viewer_v2.1a.zip if you ARE using Bret Rumsey's Image Viewer
Icon Meaning
TNG 11.0.2
indicates the mod applies to TNG 11.0.2 through current TNG 11.1
TNG 11.0
TNG 10.1.0
indicates the mod applies to TNG 10.1 through 10.1.3 and TNG 11.0 and 11.0.1 since there is a version for TNG 11.0.2
TNG 10.0
indicates the mod applies to TNG 10.0 through 10.0.3 since there is a version for TNG 10.1.0
TNG 9.2.2
indicates the mod applies to TNG 9.2.2 since there is a version for TNG 10.0
TNG 9.0.3
indicates the mod applies to TNG 9.0.3 through TNG 9.2.1 since there is a version for TNG 9.2.2
TNG 9.0.2
indicates the mod applies to TNG 9.0.2 since there is a version for TNG 9.0.3
TNG 9.0
indicates the mod applies to TNG v9.0 through v9.0.1 since there is a version for TNG 9.0.2
TNG 8.1.2
indicates the mod applies to TNG 8.1.2 through TNG 9.0.0

(Note that for TNG v8, the current mod numbering scheme did not apply to mod file names. For example in media-3_body_text_v8.1.3.zip, the v8 meant the mod applied to TNG v8 and the .1 indicate this was the 1st version of the mod and the .4 indicated it was the 4th revision. The numbering scheme at that time was kind of confusing.)

TNG 8.1
indicates the mod applies to TNG v8.1
TNG 8.0
indicates the mod applies to TNG v8.0
TNG 7.0
indicates the mod applies to TNG 7.0

Practical Examples

Mod Name Mod Version Mod File name Meaning of the TNG Mod number Meaning of z value Applies to TNG versions
Person Media Edit v9.0.3.0 person_media_edit_v9.0.3.0.cfg V9.0.3 indicates the minimum TNG version is TNG 9.0.3 .0 means this is the original mod All TNG version starting with v9.0.3 through current TNG 11.1
Same Person Link V11.0.0.3 same_person_link_v11.0.0.3.cfg V11.0.0 indicates that TNG 11 is required for this mod .3 means this is the 3rd revision for this mod TNG v11.0.0 through TNG 11.1
v10.1.0.5 same_person_link_v10.1.0.5a.cfg v10.1.0 indicates that TNG 10.1 at a minimum is required for this mod

(since there is a v11.0.0 then the mod does NOT apply to TNG 11+)

5a applies if you are also using the Simple SEO mod to resolve the conflict between the two mods
whereas 5 is the latest mod revision and does not need to be replace if you do not have a conflict
TNG v10.1 through v10.1.3 since there is a version of the mod for TNG 11
V10.0.0.1 same_person_link_v10.0.0.1.cfg v10.0.0 indicates that TNG 10.0 at a minimum is required for this mod

(since there is a v10.1.0 then the mod does NOT apply to TNG 10.1+)

.1 is the latest revision for v10.0.0 TNG 10.0.0 throught 10.0.3 since there is a version of the mod for TNG 10.1
V9.1.0.6 same_person_link_v9.1.0.6.cfg V9.1.0 indicates that TNG 9.1 at a minimum is required for this mod

(since there is a v10.0.0 then the mod does NOT apply to TNG 10+)

.6 is the latest revision for v9.1.0 TNG 9.1.0 throught 9.2.2 since there is a version of the mod for TNG 10
Tooltip Mod V11.0.2.3 media-4_tooltip_v11.0.2.3.cfg media-4 in front of the tooltip file name indicates this mod must be installed after other media mods where the file name is media-1_, media-2_, and media-3_


v11.0.2 indicates the mod requires a minimum of TNG v11.0.2

.3 indicates this is the 3rd revision of the mod TNG 11.0.2 through current TNG 11.1 version
V10.1.0.2 media-4_tooltip_v10.1.0.2.cfg media-4 in front of the tooltip file name indicates this mod must be installed after other media mods where the file name is media-1_, media-2_, and media-3_


v10.1.0 indicates the mod requires a minimum of TNG v10.1.0
(since there is a v11.0.2 then the mod does NOT apply to TNG 11.0.2+)

.2 indicates this is the 2nd revision of the mod TNG 10.1.0 through current TNG 11.0.1 version
V10.0.0.0 media-4_tooltip_v10.0.0.0.cfg media-4 in front of the tooltip file name indicates this mod must be installed after other media mods where the file name is media-1_, media-2_, and media-3_


v10.0.0 indicates the mod requires a minimum of TNG v10.0.0
(since there is a v10.0.2 then the mod does NOT apply to TNG 10.1.0+)

.0 indicates this is the initial revision of this mod for TNG 10 TNG 10.0.0 through current TNG 10.0.3 version
Age Calculation Mod V9.0.0.2 age_calculation_v9.0.0.2.cfg V9.0.0 indicates that TNG 9 is required for this mod .2 means this is the 2nd fix for this mod TNG v9.0.0 through TNG 9.2.2

This mod was incorporated into TNG v10 and is therefore obsolete for TNG v10 and v11

Body Text for Translation V7 media-3_body_text_v1.2.cfg applies to TNG V7 mod versions did not show TNG dependency TNG v7

This mod was incorporated into TNG v10 and is therefore obsolete for TNG v10 and v11

Mod Category Pages

Mods for TNG vNN categories are only created for major TNG versions such as TNG v9, v10, and v11. So if you are installing TNG 11.1, you should be looking at the Mods for TNG v11. It does not make sense for you to look at the Mods for TNG v7, Mods for TNG v8, Mods for TNG v9, and Mods for TNG v10.

If you are using TNG v11 and the mod category at the bottom of the TNG wiki page does not show Mods for TNG v11 then most likely the mod does not apply to TNG v11. It is possible the mod developer did not update the category.